using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)";
string substitution = @"$1\n$2--$3--rgb: #{$hexToRGB($3)};";
string input = @" --color-primary: #0017a8;
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-tertiary: #00ffe0;
--color-green-dark: #257426;
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}