import re
regex = re.compile(r"(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)", flags=re.MULTILINE)
test_str = (" --color-primary: #0017a8;\n"
" --variablename: blabla blablabla;\n"
" --color-secondary: #0631ff;\n"
" --color-tertiary: #00ffe0;\n"
" --color-green-dark: #257426;\n")
subst = "$1\\n$2--$3--rgb: #{$hexToRGB($3)};"
result = regex.sub(subst, test_str)
if result:
print(result)