use strict;
my $str = ' --color-primary: #0017a8;
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-tertiary: #00ffe0;
--color-green-dark: #257426;
';
my $regex = qr/(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)/mp;
my $subst = '$1\\n$2--$3--rgb: #{$hexToRGB($3)};';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";