using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]";
string substitution = @"";
string input = @"A Pro Webcam ((Good text) [[Good Text] more texts
Text (Example (Good text) [Good Text] more texts";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}