const regex = /(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\((?:[^()]++|(?1))*\\))|(\\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]', 'gm')
const str = `A Pro Webcam ((Good text) [[Good Text] more texts
Text (Example (Good text) [Good Text] more texts`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);