package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]`)
var str = `A Pro Webcam ((Good text) [[Good Text] more texts
Text (Example (Good text) [Good Text] more texts`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}