import re
regex = re.compile(r"(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]", flags=re.MULTILINE)
test_str = ("A Pro Webcam ((Good text) [[Good Text] more texts\n"
"Text (Example (Good text) [Good Text] more texts")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)