import Foundation
let pattern = #"(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A Pro Webcam ((Good text) [[Good Text] more texts
Text (Example (Good text) [Good Text] more texts
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)