$re = '/(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]/m';
$str = 'A Pro Webcam ((Good text) [[Good Text] more texts
Text (Example (Good text) [Good Text] more texts';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;