use strict;
my $str = 'A Pro Webcam ((Good text) [[Good Text] more texts
Text (Example (Good text) [Good Text] more texts';
my $regex = qr/(?:(\((?:[^()]++|(?1))*\))|(\[(?:[^][]++|(?2))*]))(*SKIP)(*F)|[][()]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";