#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)t"
Local $sString = "192.168.0.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"23.54.23.167" & @CRLF & _
" " & @CRLF & _
"// 只匹配上面的 ip 地址" & @CRLF & _
"---分割线---" & @CRLF & _
" " & @CRLF & _
"1000.1.1.1" & @CRLF & _
"192..168.0.1" & @CRLF & _
"192.168.0.1000" & @CRLF & _
"192.168.1.a" & @CRLF & _
"256.22.23.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")