# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"t"
test_str = ("192.168.0.1\n"
"127.0.0.1\n"
"23.54.23.167\n"
" \n"
"// 只匹配上面的 ip 地址\n"
"---分割线---\n"
" \n"
"1000.1.1.1\n"
"192..168.0.1\n"
"192.168.0.1000\n"
"192.168.1.a\n"
"256.22.23.4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.