import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "t";
final String string = "192.168.0.1\n"
+ "127.0.0.1\n"
+ "23.54.23.167\n"
+ " \n"
+ "// 只匹配上面的 ip 地址\n"
+ "---分割线---\n"
+ " \n"
+ "1000.1.1.1\n"
+ "192..168.0.1\n"
+ "192.168.0.1000\n"
+ "192.168.1.a\n"
+ "256.22.23.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}