using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"t";
string input = @"192.168.0.1
127.0.0.1
23.54.23.167
// 只匹配上面的 ip 地址
---分割线---
1000.1.1.1
192..168.0.1
192.168.0.1000
192.168.1.a
256.22.23.4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}