package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)t`)
var str = `192.168.0.1
127.0.0.1
23.54.23.167
// 只匹配上面的 ip 地址
---分割线---
1000.1.1.1
192..168.0.1
192.168.0.1000
192.168.1.a
256.22.23.4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}