re = /t/m
str = '192.168.0.1
127.0.0.1
23.54.23.167
// 只匹配上面的 ip 地址
---分割线---
1000.1.1.1
192..168.0.1
192.168.0.1000
192.168.1.a
256.22.23.4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end