#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w ]+).*? Your Age is: (\d+).*?email is: ([\w@].*?) Your"
Local $sString = "FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: " & @CRLF & _
"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: " & @CRLF & _
"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: " & @CRLF & _
"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")