import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w ]+).*? Your Age is: (\\d+).*?email is: ([\\w@].*?) Your";
final String string = "FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: \n"
+ "FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: \n"
+ "FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: \n"
+ "FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}