using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w ]+).*? Your Age is: (\d+).*?email is: ([\w@].*?) Your";
string input = @"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}