import re
regex = re.compile(r"^([\w ]+).*? Your Age is: (\d+).*?email is: ([\w@].*?) Your", flags=re.MULTILINE)
test_str = ("FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: \n"
"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: \n"
"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: \n"
"FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")