$re = '/^([\w ]+).*? Your Age is: (\d+).*?email is: ([\w@].*?) Your/m';
$str = 'FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is:
FirstName LastName Your Age is: 30 Your email is: email@email.com Your something is: ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);