#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([0-9]+),(.+),([0-9]+)"
Local $sString = "CODE,Name,Value" & @CRLF & _
"1,ABC (CEF) CO.,XYZ,500" & @CRLF & _
"2,GOOD VALUE CO., XYZ,20"
Local $sSubst = "\1,"\2",\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)