import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+),(.+),([0-9]+)";
final String string = "CODE,Name,Value\n"
+ "1,ABC (CEF) CO.,XYZ,500\n"
+ "2,GOOD VALUE CO., XYZ,20";
final String subst = "\\1,\"\\2\",\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}