const regex = /([0-9]+),(.+),([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+),(.+),([0-9]+)', 'gm')
const str = `CODE,Name,Value
1,ABC (CEF) CO.,XYZ,500
2,GOOD VALUE CO., XYZ,20`;
const subst = `\1,"\2",\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);