use strict;
my $str = 'CODE,Name,Value
1,ABC (CEF) CO.,XYZ,500
2,GOOD VALUE CO., XYZ,20';
my $regex = qr/([0-9]+),(.+),([0-9]+)/mp;
my $subst = '\\1,"\\2",\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";