re = /([0-9]+),(.+),([0-9]+)/m
str = 'CODE,Name,Value
1,ABC (CEF) CO.,XYZ,500
2,GOOD VALUE CO., XYZ,20'
subst = '\\1,"\\2",\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result