# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]+),(.+),([0-9]+)"
test_str = ("CODE,Name,Value\n"
"1,ABC (CEF) CO.,XYZ,500\n"
"2,GOOD VALUE CO., XYZ,20")
subst = "\\1,\"\\2\",\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.