package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+),(.+),([0-9]+)`)
var str = `CODE,Name,Value
1,ABC (CEF) CO.,XYZ,500
2,GOOD VALUE CO., XYZ,20`
var substitution = "\1,"\2",\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}