#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(?<VMX>[^\.]*)\.vmx"
Local $sString = "Caldera/Caldera.vmx " & @CRLF & _
"Cuckoo_SNDBX/Cuckoo_SNDBX.vmx " & @CRLF & _
"Win_7_cuckoo/Win_7_cuckoo.vmx " & @CRLF & _
"kali/kali.vmx " & @CRLF & _
"kali2019/kali2019.vmx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")