import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?<VMX>[^\\.]*)\\.vmx";
final String string = "Caldera/Caldera.vmx \n"
+ "Cuckoo_SNDBX/Cuckoo_SNDBX.vmx \n"
+ "Win_7_cuckoo/Win_7_cuckoo.vmx \n"
+ "kali/kali.vmx \n"
+ "kali2019/kali2019.vmx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}