package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(?<VMX>[^\.]*)\.vmx`)
var str = `Caldera/Caldera.vmx
Cuckoo_SNDBX/Cuckoo_SNDBX.vmx
Win_7_cuckoo/Win_7_cuckoo.vmx
kali/kali.vmx
kali2019/kali2019.vmx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}