re = /\/(?<VMX>[^\.]*)\.vmx/m
str = 'Caldera/Caldera.vmx
Cuckoo_SNDBX/Cuckoo_SNDBX.vmx
Win_7_cuckoo/Win_7_cuckoo.vmx
kali/kali.vmx
kali2019/kali2019.vmx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end