const regex = /\/(?<VMX>[^\.]*)\.vmx/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?<VMX>[^\\.]*)\\.vmx', 'gm')
const str = `Caldera/Caldera.vmx
Cuckoo_SNDBX/Cuckoo_SNDBX.vmx
Win_7_cuckoo/Win_7_cuckoo.vmx
kali/kali.vmx
kali2019/kali2019.vmx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}