$re = '/\/(?<VMX>[^\.]*)\.vmx/m';
$str = 'Caldera/Caldera.vmx
Cuckoo_SNDBX/Cuckoo_SNDBX.vmx
Win_7_cuckoo/Win_7_cuckoo.vmx
kali/kali.vmx
kali2019/kali2019.vmx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);