// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(?<VMX>[^\.]*)\.vmx").unwrap();
let string = "Caldera/Caldera.vmx
Cuckoo_SNDBX/Cuckoo_SNDBX.vmx
Win_7_cuckoo/Win_7_cuckoo.vmx
kali/kali.vmx
kali2019/kali2019.vmx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}