#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\b(?:while|for)\s*(\((?:[^()]++|(?1))*\))"
Local $sString = "for (int i = 3; i <= sqrt(n); i = i + 2) { " & @CRLF & _
"" & @CRLF & _
"int rows = 5; for(int i = 1; i <= rows; ++i){ "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")