use strict;
my $str = 'for (int i = 3; i <= sqrt(n); i = i + 2) {
int rows = 5; for(int i = 1; i <= rows; ++i){ ';
my $regex = qr/\b(?:while|for)\s*(\((?:[^()]++|(?1))*\))/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}