// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\b(?:while|for)\s*(\((?:[^()]++|(?1))*\))").unwrap();
let string = "for (int i = 3; i <= sqrt(n); i = i + 2) {
int rows = 5; for(int i = 1; i <= rows; ++i){ ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}