$re = '/\b(?:while|for)\s*(\((?:[^()]++|(?1))*\))/u';
$str = 'for (int i = 3; i <= sqrt(n); i = i + 2) {
int rows = 5; for(int i = 1; i <= rows; ++i){ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);