import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:while|for)\\s*(\\((?:[^()]++|(?1))*\\))";
final String string = "for (int i = 3; i <= sqrt(n); i = i + 2) { \n\n"
+ "int rows = 5; for(int i = 1; i <= rows; ++i){ ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}