re = /\b(?:while|for)\s*(\((?:[^()]++|(?1))*\))/
str = 'for (int i = 3; i <= sqrt(n); i = i + 2) {
int rows = 5; for(int i = 1; i <= rows; ++i){ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end