using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:while|for)\s*(\((?:[^()]++|(?1))*\))";
string input = @"for (int i = 3; i <= sqrt(n); i = i + 2) {
int rows = 5; for(int i = 1; i <= rows; ++i){ ";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}