import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*KGM.*\\R(?!.*MTQ)";
final String string = "1 MEA+AAE+AAB+KGM:5270.000'\n"
+ "2 MEA+AAE+AAW+MTQ:66.500' <-- OK\n"
+ "3 MEA+AAE+AAB+KGM:5158.000' <-- NOT OK\n"
+ "4 MEA+AAE+AAB+KGM:6634.000' <-- NOT OK\n"
+ "5 MEA+AAE+AAB+KGM:5081.000' <-- NOT OK\n"
+ "6 MEA+AAE+AAB+KGM:21106.000'\n"
+ "7 MEA+AAE+AAW+MTQ:25.000' <-- OK ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}