import Foundation
let pattern = #".*KGM.*\R(?!.*MTQ)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 MEA+AAE+AAB+KGM:5270.000'
2 MEA+AAE+AAW+MTQ:66.500' <-- OK
3 MEA+AAE+AAB+KGM:5158.000' <-- NOT OK
4 MEA+AAE+AAB+KGM:6634.000' <-- NOT OK
5 MEA+AAE+AAB+KGM:5081.000' <-- NOT OK
6 MEA+AAE+AAB+KGM:21106.000'
7 MEA+AAE+AAW+MTQ:25.000' <-- OK
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)