const regex = /.*KGM.*\R(?!.*MTQ)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*KGM.*\\R(?!.*MTQ)', 'gm')
const str = `1 MEA+AAE+AAB+KGM:5270.000'
2 MEA+AAE+AAW+MTQ:66.500' <-- OK
3 MEA+AAE+AAB+KGM:5158.000' <-- NOT OK
4 MEA+AAE+AAB+KGM:6634.000' <-- NOT OK
5 MEA+AAE+AAB+KGM:5081.000' <-- NOT OK
6 MEA+AAE+AAB+KGM:21106.000'
7 MEA+AAE+AAW+MTQ:25.000' <-- OK `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}