$re = '/.*KGM.*\R(?!.*MTQ)/m';
$str = '1 MEA+AAE+AAB+KGM:5270.000\'
2 MEA+AAE+AAW+MTQ:66.500\' <-- OK
3 MEA+AAE+AAB+KGM:5158.000\' <-- NOT OK
4 MEA+AAE+AAB+KGM:6634.000\' <-- NOT OK
5 MEA+AAE+AAB+KGM:5081.000\' <-- NOT OK
6 MEA+AAE+AAB+KGM:21106.000\'
7 MEA+AAE+AAW+MTQ:25.000\' <-- OK ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);