#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*<p class="amigo">(?s)(?-s)(.*)<br>*$"
Local $sString = "<p class="amigo">My mother is at home.<p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"afasf" & @CRLF & _
"" & @CRLF & _
"<p class="amigo">My mother is at home.<br>" & @CRLF & _
"" & @CRLF & _
"asfa" & @CRLF & _
"" & @CRLF & _
"asffa" & @CRLF & _
"" & @CRLF & _
"<p class="amigo">My mother is at home.<p>" & @CRLF & _
"" & @CRLF & _
"asdas"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")