$re = '/.*<p class="amigo">(?s)(?-s)(.*)<br>*$/m';
$str = '<p class="amigo">My mother is at home.<p>
afasf
<p class="amigo">My mother is at home.<br>
asfa
asffa
<p class="amigo">My mother is at home.<p>
asdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);