using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*<p class=""amigo"">(?s)(?-s)(.*)<br>*$";
string input = @"<p class=""amigo"">My mother is at home.<p>
afasf
<p class=""amigo"">My mother is at home.<br>
asfa
asffa
<p class=""amigo"">My mother is at home.<p>
asdas";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}