package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*<p class="amigo">(?s)(?-s)(.*)<br>*$`)
var str = `<p class="amigo">My mother is at home.<p>
afasf
<p class="amigo">My mother is at home.<br>
asfa
asffa
<p class="amigo">My mother is at home.<p>
asdas`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}